FireFox перестал поддерживать плагины. В чем причина?

У некоторых сотрудников в моей организации перестал работать сайт Госуслуг и Клиент-Банк, выяснилось, что они пользовались браузером FireFox и после автоматического его обновления до версии 52, данные сайты перестали работать. Оказалось, что в данной версии, разработчики отказались от поддержки определенных плагинов, по этому и произошли такие сбои. По этому, давайте рассмотрим, как все это выглядит и как с этим бороться.

Переходим на сайт https://www.gosuslugi.ru пытаемся выполнить вход в личный кабинет и выдается сообщение, что плагин не установлен, хотя это не так. Для проверки перейдем в Меню \ Дополнения \ Плагины. И видим, что разработчики нас предупреждают, что некоторые плагины больше не поддерживаются, перейдем в Подробнее.

Если вкратце, то  это сделано для увеличения производительности и безопасности браузера, хотя и в минус некоторым функциям. Но, чтобы не делать процесс перехода к новой версии критичным, была разработана специальная версия FireFox ESP с расширенной поддержкой, которая поддерживает все прежние функции браузера. Скачать её можно по ссылке в самом низу.

Следуя рекомендациям, я бы лучше установил версию для 32 битной системы, так как 64 битная так же поддерживает не все функции.

Устанавливаем и видим, что появился плагин Crypto Interface Plugin, это как раз тот плагин, который требуется для работы через электронный ключ с сайтом госуслуг.

Так что, если у ваших клиентов или пользователей появились какие-либо проблемы с работой сервисов и у них браузер FireFox, то, скорее всего он самостоятельно обновился  и больше не работает с плагинами. Тогда устанавливаем дополнительную версию, но все равно, потом придется искать другой вариант, так как он будет работать только до конца 2017 года. Можно использовать устаревшую версию, но это тоже не вариант, так как вы подвергаете свой компьютер интернет угрозам.

В следующем видео  я расскажу про автоматическое открытие страниц в разных браузерах. Это очень актуально, в ситуации, когда разные сервисы для корректной работы требуют использовать различные браузеры!

Комментарии (5)

В сторону FireFox, дорогу Хрому!!! У моих юзеров постоянно какие-то траблы были с мозилой, пока не поставил всем Хром. Но на ОС ХР это не всегда прокатывает...

  Вложения
 
  1.    Местный IT'шник

Да, но в internet explorer очень много тонких настроек, с которыми меня юзеры просто убивают, для работы с цифровой подписью.... и т.д.

  Вложения
 
  1.    Сергей

А так по факту нечего сложного нету. Больше проблема иза старых IE, обновляете до актуальных и всё проблема решается.
Цифровые подписи, и различенные сайты по документ обороту, не воспринимают другие браузеры кроме IE

  Вложения
 
  1.    Сергей

Тут все зависит от требований разработчика сайта, с которым работает пользователь. Вот именно ради решения подобной проблемы записал видеоурок "Автоматическое открытие страниц в разных браузерах" - http://sys-team-admin.ru/videouroki/raznoe/106-avtomaticheskoe-otkrytie-stranits-v-raznykh-brauzerakh.html. Чтобы удобно пользоваться рабочими сервисами.

  Вложения
 
There are no comments posted here yet

Оставьте свой комментарий

Опубликуйте комментарий как Гость. Иначе Зарегистрируйтесь или Войдите в ваш аккаунт.
Вложения (0 / 3)
Share Your Location
Отправляя комментарий вы соглашаетесь с Политикой конфиденциальности
Вверх
Политика конфиденциальности Используя сайт вы даете согласие на обработку персональных данных